ちぇりーごー

ただのギャンブラー

imongoインストールメモ

iMongoインストールメモ
https://github.com/gusutabopb/imongo

3.x.x系でないと動かないので、pyenv環境をつくる。

pyenvとvirtualenvで環境構築 - Qiita

お目当ての3.x.x系をインストールしようとするとエラー。
以下記事。xcode command line developer toolsが無いのが原因。

pyenvにおけるpythonインストールエラー対処法(BUILD FAILED) - Qiita

3.6.0をインストール。3.x.x系で作業することが増えたので、グローバルに変更。
imongoインストールの続き。


setup.py installが通らない。

ModuleNotFoundError: No module named 'jupyter_client'

以下で解決。

pip install --upgrade jupyter